Can’t define product on Ghost with Snipcart

I define my first product in Ghost using Snipcart. On the developer logs, it said that my product has been found and imported successfully. But still, the link doesn’t work. It said: We’re getting your cart ready…

Do you know what’s happening? Should I wait 24h for it to function?

My threads on Twitter about this problem

@cyoseffa I checked your site and it seems that you have set the local of the website to “en en” which is the root of the issue here. I checked the pagesource of the site and as you can see in the screenshot below it has two en.
Screen Shot 2022-05-02 at 9.35.31 AM
Can you set it to this instead and see if that helps?
Screen Shot 2022-05-02 at 9.33.48 AM

1 Like

Thank you so much for the swift reply. I tried with these 4 options. And still not working. 🥲

Option 1

<html lang="en">

Option 2

<html lang='en'>

Option 3

<html lang="{{ @site.locale }}">

Option 4

<html lang='{{ @site.locale }}'>

I’m eager to hear your feedback :blush:

@cyoseffa I checked the site and still see the site lang config set to “en en”. Can you make sure to check the site page source view-source:🛍 For Business Owner after you make changes to make sure it stays en?

let us know if that helps!

@ppanth Thank you so much, Prashant! It’s working now. :smiling_face_with_three_hearts::smiling_face_with_three_hearts:🥹

1 Like